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By Choice Player

By Choice Editor

Editor Levels

1. Overview

Communicate: By Choice is a program designed to create and use a
wide range of activities which present “question and answer” tasks
to students. These can range from very simple tasks for students with
severe learning difficulties, to much more demanding cognitive tasks
suitable for use in mainstream primary education and across the age
range in special education.

The 100 activities provided with the pack cover basic skills for years 1
and 2 of mainstream education and a wider age group in special 
education. We also provide a number of other example activities to
show the potential of the program. Widgit will be providing support
packs covering other areas. Teachers and resource providers can also
develop their own activities using the program.

The pack has two components:

The Player is the program used to run the created activities and is 
the program that students will use. It is available from the Start 
menu: Widgit->By Choice->By Choice Player

The Editor is the program used to create, edit and test activities. 
This is for use by the teacher or anyone preparing or editing the 
activities. It is available from the start menu: 
Widgit->By Choice->By Choice Editor

The editor has three levels of use:

(a) Edit Only, which can be used to edit and re-purpose existing 
activities.

(b) Create and Edit, which allows the creation of a range of 
activities and also has extra editing features.

(c) Expert, which unlocks the program’s full functionality.

There will also be shortcuts to these programs on your desktop, if
that option was selected at the time the software was installed.

This manual deals with the ‘By Choice Player’ and the ‘Edit Only’
aspect of the Editor. This will allow the majority of users to do 
everything that they need to do. Additionally, there are PDF tutorials
for the ‘Create and Edit’ and ‘Expert’ modes. These tutorials are 
available from the start menu:

Widgit->By Choice->Create and Edit Tutorial
Widgit->By Choice->Expert Tutorial
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Logging-on 
and browsing
folders

2. Using the Player

The By Choice Player is a program that you can use to browse and
view activities created with the By Choice Editor. The Player can 
provide feedback during use and also produce a ‘progress sheet’ at
the end of each activity that can be used to record the student’s 
performance. The following will illustrate some of the features of
the Player.

2a A first look at an activity

Launch the program from the start menu:
Widgit->By Choice->By Choice Player

The log-on screen appears as shown. A dialog box enables the user,
or their teacher or carer, to type in the name of the user. The name
of the user will then be shown in the ‘progress sheet’ at the end of
each activity.

You do not have to enter a name if you do not want to. Press Return
on your keyboard, or click the OK button on the screen to continue. 
The screen then shows the folders that contain activities.

5
© Widgit Software 2005 



Making correct
and incorrect
responses

On each folder there is an image to help describe the folder’s
contents and below each folder is the folder name. When you click
on a folder you will see the folder’s contents. This will usually be the
activities in that folder, but it will also show any sub-folders. To
return to the previous folder, click on the up arrow in the top-left
corner of the screen. In the bottom right of the screen are two icons
which are used when the page is full. These are to go to the next
page or back to a previous page. These are grey if they do not apply. 

Activities in the folders are shown by their file name and by a 
thumbnail of the first page of the activity. This makes it easy to find
the activity you want.

Use the front screen to select Other examples folder and then the
match car 2 activity. The activity will load. It is useful to look at this
example as it is designed to illustrate a range of features.
A similar activity will be used to illustrate the methods of editing files
in Section 3.

Make an incorrect response. When you do this you will see a visible
indication that the answer is wrong. This occurs when you click on a
distractor or when an answer is selected at the wrong time, for 
example, in a sequencing activity. The activity will also play a sound
to give an audible indication that the answer is wrong (unless this
facility has been switched off – see the next paragraph). 

If you do not want to hear a sound when a wrong answer is selected,
go to the Configure menu and uncheck Hear wrong answer sounds. 
If you look at the menu again, you will see that the tick beside ‘Hear
wrong answer sounds’ has been removed. The default behaviour for
‘Hear wrong answer sounds’ can be set as described in Section 3k.

When you choose the 
correct response, you will
receive whatever positive
feedback was set when 
the activity was created,
such as a reward animation
or a sound being played.
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Activities can
have several
pages

An activity can continue through several pages. Continue through 
the activity and deliberately make mistakes on page 2 and get the
answer right first time on page 3.  When you get to the end of an
activity, a progress sheet will appear that will look like the one shown
below.

The progress sheet shows the name of the activity, the name of the
student (if one was entered), the current date and an indication of
what was achieved on each page. A star is used to indicate the 
student’s performance on each page. A gold star (large size) indicates
that the page was answered without errors. A silver star (medium
size) indicates that the page was answered with relatively few errors.
A bronze star (small size) indicates that the student made a great
deal of errors. No star at all shows that the student was confused by
the page or was unable to answer sensibly. A dash indicates that the
page was skipped (for example by deliberately pressing the Page 
Up key).

The stars appear in the same order as the pages in the activity, which
will help the teacher review the work of a student. Where the
student achieves a bronze star, or no star at all, the teacher may want
to work with the student to discover the reason.

At this point, the page can be printed (unless this facility has been
switched off – see the next paragraph). No printer dialog box is
offered so all the student needs to do is to click the print button. The
page is sent to the default printer. 

If you wish to allow the student to see this page but not to print it,
then you can go to the Configure menu and uncheck Enable 
printing button to disable the printing button. This takes effect next
time you view a progress sheet. The default behaviour for ‘Enable
printing button’ can be set as described in Section 3k.
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Auto-progress

The progress report also has a continue button (an arrow pointing
to the right). Select this to move on.

What happens now depends on whether Auto progress has been
enabled in the Configure menu.

If ‘Auto progress’ is not enabled, the program will return to the
main screen in the same folder as the activity just used. The log-on
dialog box will be displayed. The current student’s name is shown in
the log-on dialog box and simply clicking OK or pressing return on
the keyboard allows that student to continue. Alternatively, the
teacher may choose to allow a different student to use the program
and change the name. In either case, a new activity can now be
selected.

If ‘Auto progress’ is enabled, then instead of returning to the folder
screen, the program will continue with the next activity in the
folder. When the last activity in the folder has been completed, the
program will return to the main screen and the log-on dialog box
will appear. You can therefore use ‘Auto progress’ to allocate a
longer series of tasks to a student. This is discussed further in Section
3l. The default behaviour for ‘Auto progress’ can be set as described
in Section 3k.

You can close an activity by selecting Close from the File menu.

2b Description of range of activities

The activities supplied with the pack are designed for early years 
primary and a wider age range in special education. There are other
packs in preparation to cover a greater variety of curriculum topics
and student needs. These will be available as low cost downloads
from our website, or groups of resources may become available on
CD. In this pack the activities have been arranged in topic folders.
Folders in the pack include:

Colour and Shape
General Activities
Language Comprehension
Letter work
Number
Science
Sequencing and Sorting
Visual Discrimination
Memory
Word work
Other examples
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Activities with
more than one
answer

The names of the folders and the icon on them indicate the nature of
the work. Activities inside have been divided into five standards of
difficulty. The difficulty is indicated by a letter A-, the easiest, then 
B- and through to E-.  These letters should only be taken as a general
indication as students will differ in their perception of the difficulty.  

The activities have been arranged in this way to enable easy access in
a classroom where differentiated activities are needed. In Section 3l
you will see how you can easily choose to allocate activities to a 
student, or group of students working collaboratively. The order in
which the activities are presented can also be allocated.

There is an additional folder Other examples with examples that are
outside this range. These are titled separately. 

2c Looking at a range of activities

In this section a range of activities will be described to illustrate the
scope of styles as well as educational content.  

From the Visual discrimination folder select A-find 2 cars.

In this case two answers need to be selected before the activity
moves on. The instructions are shown visually with text and symbols
and the instruction is read out. If a student wishes to hear the
instruction again then they can click on the speech bubble. Notice
that while the voice is speaking the mouse click is disabled – the 
student must wait for the speech to finish before making their
selection.
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Pages that 
reveal layers

Matching using
two clicks

Other examples of this type of activity include:
Colour and shape\B-find all colour 5 of 8
Language Comprehension\B-what where

A layer is an extra set of objects that can be revealed as questions on
a page are answered. From the Number folder select C-blackboard
adding. The screen below shows what you see after three correct
answers have been given.

This feature is useful in limiting what is displayed at any one time, so
allowing the student to easily focus on a particular question.

Other examples that use layers include:
Language Comprehension\E-guess what
Visual Discrimination\E-swan picture

Questions that involve
matching are sometimes
best done by asking the 
student to select an 
object and then its match. 
To illustrate this from the
Visual Discrimination
folder select D-animal
shapes.
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Pages where
answers must 
be in order –
sequencing
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Here the student should click on an animal and then on its 
matching shape (or the other way round). The screen shot shows 
the activity appearance after the first match has been correctly made.

Other examples using two clicks include:
Word work\D-picture word matching 
Word work\D-prepositions

The program can run activities where the answers must be selected in
a particular order, shape sequencing, anagrams and sorting into
alphabetical order are some examples. From the Sequencing and
Sorting folder select C-fishy sequence.

This screen shows one of the pages after the first selection has been
made. When the sequence is completed there is a reward sound and
animation, before the program moves on to the next screen.

Other examples using sequencing include:
Letter work\D-alphabet words 1
Word work\Spelling with sounds\E-anagrams



Grouping by
selecting objects
in sets

Grouping using
two clicks

In these examples objects must be grouped by selecting all objects of
one sort, then all of another, and so on. It may not matter which
object is selected first, but then all objects in that group must be
selected. The program can, however, insist that objects of one sort
are selected first – for example ‘Find all the red things, then find all
the green things’. From the Colour and Shape folder select C-two
colours.

Other examples of grouping include:
Science\C-animal sorting

An alternative approach to grouping is to ask a student to select an
object and then the group to which it belongs. From the Science
folder select C-heavy or light. The spoken instruction explains what
to do. The following screen shows the second page half completed.
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Stacked 
presentation

Other examples using two clicks to group include:
Language Comprehension\C-function pairs
Word work\E-opposites

In some cases it is a good idea to have the alternatives stacked on top
of one another and then you can“turn them over” in sequence.
This gives more screen space and can model “snap” games.
From the Letter work folder select C-Upper case snap 1.

When the turn icon is selected, the letters on the right will be turned
over. The student should select the lower case “b” to match the
upper case “B”. 

Other examples using stacked presentations include:
Visual Discrimination\A-snap animals
Word work\D-picture word snap
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Another open-ended example is: 
General Activities\what I like

Short term memory activities can be created using the “cover” 
feature of the program. Here the options are presented for a short
time and then covered over. The student must select the correct
answer, which is hidden underneath the cover. If wrong selections are
made the images are re-covered. From the Visual discrimination
folder select E-symbol pairs cover. This is an activity for more visually 
difficult symbol matching and memory – it is quite hard!

Any answer
question

Cover and short
term memory

The program can also present questions that have open answers. The
following example creates a weather diary page. The program can
print out the white “print area” as a record. From the General 
Activities folder select today. The following image shows the page
after completion, ready to print, by selecting the print button on
the screen.
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Overview

Creating a switch
settings file

The first screen shows the second page of the activity. All objects are
then covered after a short time. The second screen shows the display
after two pairs have been found.

Another example using cover is:
Memory\B-food pairs

2d Using switch access 

The activities supplied with the pack have been set up so that a
switch user can access them. The folders and files in the folder 
browser can also be accessed by switch use. You can save a ‘switch
settings file’ for each student with the switch settings that are most
appropriate for him or her. This file should be saved with the same
name that the student uses to log into the program. When a student
logs in, the program will check for a ‘switch settings file’ with the
same name. If it finds one then it will load it and use those switch
settings until the student logs out. 

Run any activity. From the Configure menu, select Switch settings.
The following dialog box will appear:

Notice:

• The Scan rate only applies to ‘one switch’ mode. It will be disabled 
when in ‘two switch’ mode.

• The program can accept input from devices that emulate the 
keyboard, or that emulate joystick fire buttons, provided that these 
devices plug into the USB socket. Keyboard devices (e.g. the Don 
Johnston box) should be set to translate the switch inputs in to 
“space” and “return”. For single switch input, the switch box should 
be set to generate a “return”.
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Using the switch
file

Using default
settings

Turning 
switching on 
or off

For USB devices that emulate joystick switches (Crick and Sensory
Software), you should use inputs 1 and 2 and run no additional 
software. ‘By Choice’ reads these devices directly.

• Some switches accidentally generate a number of rapid signals 
when pressed. This can cause the cursor to move on more than one 
space. To prevent this, the bounce delay can be set to a time to 
include the false signals. Usually, 1 to 2 tenths of a second is fine. 
This effectively gives a “dead time” for the period after the first 
switch is pressed.

• The minimum time that a switch must be held to activate the signal 
can generally be left at zero. This is useful for students who may hit 
a switch accidentally; you can then reject these presses and only 
include a more deliberate press, where the switch is held down for 
a longer period. It is this period that you can set here. Note that the 
setting is in units of one hundredth of a second.

• The cursor thickness can also be set along with the colour. 
The subsidiary colour is only used in ‘two click’ answer activities – 
see Section 2b.

• Finally, you can use auditory scanning. For this to be of value the 
user must be scanning text objects OR the activity must have been 
created using ‘help’ text attached to any graphic that is scanned. 
The creation of activities for auditory scanning is described in the 
‘Expert Edit’ PDF documentation. The examples supplied with the 
pre-fix A- have auditory text added for you to try. You can also 
switch auditory scanning on and off using the Configure menu and 
selecting Auditory scan.

Set the values and colours as you require and then go to Save these
settings as... Enter the name of the student, exactly as you would in
the log-on dialog box, and save the file. 

Go back to the log-on screen and type in the name of the student –
being careful to use the same name that you gave for the switch file.
Click the OK button, the switch properties will operate and switches
can be used.

If you want the Player to start up using switches, then create a file as
described in 2 above and save it as ‘Default’. Enter ‘Default’ as the
user name when you run the Player.

You can turn switching on or off at any time by selecting Use 
switches from the Configure menu. 
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3. Using ‘Edit Only’

This section assumes that the reader is familiar with the main 
techniques used for Communicate: In Print 2

Run the By Choice Editor. This is available from the Start menu:
Widgit->By Choice->By Choice Editor

There will also be a shortcut to the program on your desktop, if that
option was selected at the time the software was installed.

3a Looking at a file in edit mode

From the File menu choose Open and then select blue car from inside
the Other examples folder.

On the top toolbar you will see the Go button. This allows
you to test the activity that you’re working on. To see what
the ‘blue car’ activity does, click on the Go button (or press 
Ctrl + J) and try the activity.

When you have finished, return to the edit mode by selecting File
then Return to editor or by pressing Ctrl + J on the keyboard.
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On this screen you can see:

• the instructions - a box with symbol text

• a question/answer pair -  the blue cars 

• distractors (incorrect responses) - the other three cars



Notice:

• The instructions

The symbol writing frame shows the instruction for the activity in 
text and symbols. You will have noticed that these words were 
spoken when the activity was launched, you will see how this is 
achieved shortly. 

• Question/answer pair

Most activities will have one or more question/answer pairs. The 
pairs are indicated with corresponding numbers. The question’s 
position is marked with a black number and the answer’s position is 
marked with a red number. The position of the question shows the 
position of the object when first displayed.  The answer’s position is 
shown with a hatched background and will appear when the 
correct response is given. Question/answer pairs have green drag 
points.

• Distractors

An object that should be registered as an “incorrect response” is 
called a ‘distractor’. These have light blue drag points.

3b Changing the graphics

You might want to use the ‘blue car’ activity, but with different
images; so we are going to change the graphics in the activity to be
insects instead of cars. 

To change the graphics, press the Edit Graphics button. When ‘Edit
Graphics’ is selected, the ‘Edit Graphics’ button will display a yellow
background and the graphics panel will be visible. You can click on
any graphic in the graphics panel and then on the graphic you want
to change. The graphic will be replaced with the one from the 
graphics panel. 

We want to change the activity so that the student chooses a 
“beetle” from a set of insects. Use the graphics panel to go up a
directory to the main Widgit Pictures area (or press the Widgit
Pictures button) and then choose animals. Select the green beetle
and then click on the blue car that marks the position of the question 
(indicated by a black number ‘1’).  You will see both the question 
and answer change to be the green beetle.

18
© Widgit Software 2005 



19
© Widgit Software 2005 

In a similar way, change the three distractors for the three
other insects.

3c Changing the text

The instructions for the activity are now incorrect. To edit the 
instructions, select the Edit Writing button. You will see that the 
button background becomes yellow and that the text panel has
opened on the right hand side.

You can edit the text to say, “Find the beetle” instead of “Find the
blue car”.  After you have done so, go to Save As and save your file
with a new name. Be sure to go to ‘Save As’ so that you do not 
overwrite the file you have been editing – others may want to use
this tutorial and have access to the original file!



Use the Go button to test the activity. 

Now we are going to edit an activity with a few more features. 

From the File menu, choose Open… and then select match car from
inside the Other examples folder. We’re going to make a few
changes to this activity, so let’s save it to a new file. Go to Save As
and save the file with a new name. Be sure to go to ‘Save As’ so that
you do not overwrite the original file. 

Click on the Go button to see what this activity does. This activity is
very similar to the ‘blue car’ activity, but it is a matching activity and
has an animated reward.
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Changing the
graphics and 
text

On the screen shown on page 20 you can see:

• the instructions – a box with symbol text
• a comparison object – the top left blue car 
• a question/answer pair -  the blue cars with numbers
• distractors – the three other cars
• an animation – the ring of stars

• The instructions
The symbol writing frame shows the instruction for the activity in 
text and symbols.

• Comparison object
The blue car underneath the instructions is there to show the 
student what to match.

• Animations
The stars show the position that the animation reward will play in. 
Sometimes you may want to see what the screen looks like without 
the rewards showing. To do this go to the View menu and click on 
Show reward positions to un-check it. The reward will now be 
hidden. To switch it back on go to the View menu and again click 
on Show reward positions.

Replace the graphics and text as in the first activity. Remember to
also change the comparison blue car to match the question/answer
objects.  

To finish the graphics you may want to tidy up their relative sizes.
Also, the reward animation may not be centrally positioned over the
answer. To reposition the reward or answer, you can use the 
following methods:

(a) Go to the View menu and use Show reward positions to hide the 
reward. Then you can click on the answer and re-position it. 
(If you cannot see the reward then go to the View menu and 
select Show reward positions, then reposition the reward as 
you see fit.)

(b) If you want to move the answer whilst still seeing the reward 
(which is most likely), then hold down Ctrl and click on the 
reward twice. The first click will highlight the reward and the 
second will delve to the answer underneath. You can then move 
the answer. This technique will be familiar to users of ‘In Print’
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Use the Go button to test the activity at this stage of editing.

You will find that when the activity runs it, correctly, says 
‘Find another beetle’, but when you select the answer (the green
beetle) you still hear the message and sound for the car. We’ll look 
at why the activity correctly says, ‘Find another beetle’ in a moment.
For now, let’s edit the properties of the question/answer (the green
beetle).

3d Changing the properties

Click on the question (the green beetle with the black
number) and then on the Edit Properties button. You
will see the following dialog box on the right of the
screen. 

In the ‘Speech’ section there are three edit boxes.

• The first shows what is spoken when this object is 
first displayed.

• The second shows what the object will speak if it is 
incorrectly selected. It is not possible to incorrectly 
select it in this activity, but in many activities the 
order of answering may matter and it may be useful 
to give some audible feedback to an incorrect 
selection. This speech entry can also be used for 
distractors, which are always wrong.

• The third shows the speech that will be used when 
the object is correctly selected. Edit this now to 
change it to something like “Well done! You have 
found the beetle.”
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Similarly, in the ‘Sounds’ section are spaces for three sounds. The ‘car
horn’ is not very appropriate here, so click on Browse and choose a
different sound. When you have done this, click OK. Click on Save to
save the changes, or Save As if you didn’t save your file with a new
name earlier. Now press the Go button to see the effects of the
changes you have made.

Note: Many of the sound files have a number after the file name
which indicates the length of the sound, e.g. Animals\honeybee4_5 is
4.5 seconds long.

You should find that the activity now functions correctly. 

You may be wondering why, after you have made the first changes to
the activity, the speech when the activity started was correct, i.e. ‘Find
another beetle’. Click on the symbol writing frame at the top and
then on Edit Properties. You will see the following 
dialog box on the right of the screen.

You will see that there is an entry here called 
Speak – On Display. The dialog box informs you
that this is set to speak what you see on the 
screen, i.e. the words “Find another beetle”. 
So this speech was changed automatically when
you edited the text.

In some activities, you may also want to allow a 
student to hear the instruction again when they
click on the text. So type, “Find another green 
beetle” in the Speak – On select box. There is no
need for this to be the same as the text displayed.
Now click OK and run the activity.

3e Making a short-term memory activity

You can easily make the activity into one that involves short-term
memory by pressing the Add Cover button. A dialog box will appear
from which you can select the graphic that will cover the options
after they have been displayed for a short time. Do this and try the
activity to see the effect. Do not worry if the ‘cover’ graphic does not
cover the other graphic fully in Edit mode. When the activity is run,
the ‘cover’ graphic will replace the graphic being covered until it is
clicked on, then the covered graphic will be revealed. A rising scale
will play during the time before the images are covered. You can also
set this delay before the objects are covered from this dialog box. 
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Do not try to edit an activity while Add Cover is switched on. Switch
it off by pressing the Remove Cover button, edit the activity and then
press the Add Cover button to switch ‘cover’ back on.

3f Randomising positions

You may have noticed that when you run the activity that the 
positions of the question and distractors are randomised. This is 
useful for most activities, but in some cases you may want to present
the questions and distractors in fixed positions. To do this, go to the
Edit menu. You will see that Randomise questions is ticked. Click on it
to switch randomise off. To switch it on again, go to the Edit menu
and click Randomise questions again. This setting is saved with 
the activity.

3g Making more pages of the same type

In ‘Edit Only’ mode, you can copy a page so that you have a base
from which you can change the graphics and text. This means that
you can add more pages to the activity. In ‘Edit Only’ mode, it is only
possible to add more pages of the same type – you cannot change
the basic nature of the activity from one page to the next. 

You can insert a new page in an activity either before or after the
page you are currently working on. Generally, you will be on the last
page and will want to insert a new page after the current one. Click
on the Insert Page button from the Page toolbar.

You will be asked whether you want to insert the page before or
after the current one. The default is ‘after’. A dialog box then
appears telling you that a new page will be created. Click OK. The
new page will look just like the current page, but you will see that
the page number in the Page toolbar at the bottom of the screen has
changed, as have the total number of pages. Edit this new page as
has been described, but replace the insects with something else. You
can go forward or backwards at any time to compare this page with
the one from the example, or to add new pages.

‘Insert page icon’ 



Try editing a range of activities to get some practice. Good ones to
try are detailed below. In each case there is a note to help you
complete the editing.

1.  Number\A-counting 1

Change the graphics on each page. Also, on each page, select the
answer graphic and then the Edit Properties button. Change the 
spoken text to match the graphics.

2.  Letter work\D-alphabet words 1

Here you can edit the text in each text box. You will need to be sure
that the words you use are in the same alphabetical order as the ones
you are changing. You might also like to try editing the background
colours from the menu item Frames and Pictures then select
Background Colour.

3.  Visual Discrimination\A-match - similar

This one is all about animals. Try modifying it to be about food, for
example.

Edit the graphics. You could try two ways of doing this:

(a) Find the graphics from the Widgit pictures folder for cake, 
biscuit, etc.

(b) Find the graphic from the Use List tab. This is the third tab on 
the right hand graphics panel. Some foods you could find 
include: broccoli, lettuce, green beans and cabbage. 

Experiment with Use List tab to find other foods that are in the
Symbol List rather than the Picture List.  

4.  Science\C-heavy or light

Change this to be an alternative activity on floating and sinking.  
Edit the instruction frames – instead of heavy and light, make it float
and sink (remembering to set the correct graphic for sink). Then
change the other graphics by replacing the heavy items for ones that
sink, and the light items for ones that float.

Be sure to edit the spoken instruction: Click on the place where the
word ‘heavy’ was (now float) and then on the Edit Properties
button. Edit the Speak - On display text to give the correct 
instruction for the new task. 

You may need to move the ‘reward graphic’ to get to the items
underneath it, and then put it back afterwards.
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3h Editing activities with Layers

There are many activities supplied with the pack that use the idea of
‘layers’. A layer normally consists of some graphics and text that are
revealed as the activity progresses. Using the more advanced editing
options it is possible, for example, to allow for a correct selection to
reveal another layer.

From the File menu, use Open… to load the activity match many
from the Other examples folder. Press Go to try this activity and find
out what it does. Return to the Editor when you have finished.
Feedback has deliberately been left out of this activity so that you
can use what you learned in the editing section to add your own. 

Before you begin, go to ‘Save As’ and be sure to save the file with a
different name. Edit what you see on the page to ask a different
question – For example, change the question ‘Find the car’ to ‘Find
the cake’. To reveal the second layer, click on the red Layer up arrow
as indicated. 

This will reveal the 
second layer, which you
can then edit. Click again
and edit the third layer.
When you have edited all
the layers you should 
finish up with something
like this:
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Cover Hint

Layer Hint

Test what you have done.

Now it’s time to add some feedback. We want the question on each
layer to be spoken when the layer is revealed. We will refer to the
‘Find the cake’ example but you can change the instructions as you
see fit. 

• Click on the instruction ‘Find the cake’ and then on Edit Properties. 
In the Speak – On display box, type something like ‘Can you see 
the tasty cake?’ and then click OK. 

• Click on the question graphic for ‘cake’ with the black ‘1’, and 
then on the Edit Properties button. In the Speak – On correct box, 
type, ‘Yes this is the birthday cake.’ and then click OK.

• Click on one of the distractors for this question and then on Edit
Properties. In the Speak – On incorrect box, type, ‘This is not a 
cake, this is a bun.’ Then click OK.

• Treat the ‘biscuit’ similarly.

To navigate through the different layers, click on the red Layer up
and blue Layer down buttons. The appropriate button will become
grey when you reach the lowest or highest layer. If you cannot see
the second layer, click on the red Layer up arrow and add feedback
to each item on that layer in exactly the same way as you did for the
first layer. Finally, repeat for the third layer. Save your activity and
test it.

3i Editing other activities

You can edit many of the activities that come with the pack, or others
that have been created, using these techniques. It is always a good
idea to look at the activity first and make sure that you understand
what the activity is doing. Also work from a copy of a file rather than
the original.

Do not try to edit an activity while ‘Add Cover’ is switched on.
Switch it off by pressing the ‘Remove Cover’ button, edit the activity
and then press the ‘Add Cover’ button to switch ‘cover’ back on.

Look at the ‘Layer up’ and ‘Layer down’ icons. If these are coloured
then there are other layers that you can edit. If both layer icons are
grey, then there is only one layer on the page. If the ‘Layer down’
icon is grey, then you are looking at the bottom layer for the page
and cannot go any lower. If the ‘Layer up’ icon is grey, then you are
looking at the top layer for the page and cannot go any higher.
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In many activities you will find question and answer pairs that have
been given a letter as well as a number (e.g. 2A, 2B). These are 
question and answer pairs that have been made part of a “set” 
in order to create a particular type of activity. They can be edited 
in exactly the same way as the question and answer pairs in this 
tutorial. 

If you need to change an activity in a way that is not possible with
‘Edit Only’ mode, then you will need to study the documentation
provided in the ‘Edit and Create’ and ‘Expert’ mode. These allow you
to make your own activities, as well as providing more extensive
editing capabilities. There are tutorials that you can access from the 
Start menu:

Widgit->By Choice->Create and Edit Tutorial
Widgit->By Choice->Expert Tutorial

3j Setting activities for switch access

For an activity to work successfully with switches it is necessary to set
the order in which objects are scanned. Since objects can be placed
anywhere on the screen and created in any order, it is not possible
for the program to automatically produce a sensible ‘scan order’, so
you will need to set the scan order yourself. This section tells you
how to set the scan order. (Note: All the activities provided with the
pack have already had a scan order set, so you will only need to set a
scan order for new activities, or if you want to change the scan).

Load the activity for which you want to set the ‘scan order’. From the
Edit menu, select Scan order->Define/View order. You will see that
the numbers showing the question/answer links disappear and that a
new number appears beneath each of the scannable objects. If these
numbers are not zero, then what you see is the current scan order. If
they are zero (or some are zero), then the scan order for the activity
has not been set correctly. 

All you do to set the scan order is select Scan order->Define/View
order from the Edit menu, then click, with the right mouse button,
on the objects in the order that you want them to be scanned. If you
make a mistake, you can start again, as it only takes a few minutes.
Repeat this on each page in the activity. When you have finished,
click anywhere with the left mouse button.

Hint: If you are making a new activity (in ‘Create and Edit’ or ‘Expert’
mode), you should set the scan order on the first page. Then, if you
copy or clone pages, the scan order will be copied to the 
next page.
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Scanning two
separate areas

If you want to clear the scan order to set all the numbers to zero
prior to starting again, you should select Edit->Scan order->Clear
order.

Look at the example in the Other examples folder called dino pairs.
Press Go to run it, then from the Configure menu select Use
Switches. Use the spacebar to switch between items and the ‘Return’
key to select them. You will see that the program starts by scanning
only the dinosaurs. Once a dinosaur has been selected, the program
then starts to scan the names. When the correct name has been
selected, the scan on the remaining dinosaurs will resume. 
There are therefore two separate scan groups, as otherwise objects
would be scanned unnecessarily.

To see how this is achieved go back to Edit mode and select Scan
order->Define/View order from the Edit menu. Notice that there are
two separate scan groups, one in blue on the dinosaurs and one in
red on their names. Now select  Edit->Scan order->Clear order to
clear this so that you can try it for yourself.

Select Scan order->Define/View order from the Edit menu, then click
with the right button on the dinosaurs in the order that you want
them to be scanned. After you have clicked the last of the six
dinosaurs, press the F5 function key on the keyboard. Pressing the F5
key tells the program that you want to start a new scan group. Now,
click with the right mouse button on the six names in the order that
you want them to be scanned. When you have finished click 
anywhere with the left mouse button. You will see the dinosaurs
numbered 1-7 in blue and the names numbered 1-7 in red.

Note: 

(a) You could click on the names first, then F5 and then the 
dinosaurs. This would mean that the names were scanned first.

(b) It is not possible to have more than two scan groups.
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3k Setting the defaults for the Player

There are three settings for the Player that can be set as defaults.
These are:

• Enable button printing
• Hear wrong answer sounds
• Auto progress

In Player these can be changed at any time from the Configure menu.
This will not, however, change the default setting when the Player is
first launched.

To change the default settings, run the Editor and select Start-up
preferences from the Options menu. From the Start-up preferences
dialog box, select the System and Printing tab. On this tab you will
see that you can change the default settings for Enable button 
printing and Auto progress.

To change the default setting for ‘Hear wrong answer sounds’, you
need to select the Speech, Sound and Spelling tab.
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Adding a 
student file

3l Managing the activities

The activities supplied have been arranged in folders as described in
Section 2b. You can copy these activities into individualised work
sequences. There is a folder called ‘Users’ already set up and this 
section tells you how to add individual student folders inside this.
Each folder will show an image that the student (or group) can
recognise and so it is easy for them to locate their work. 

Note: To do this setting up, you must be logged-on to the computer
with sufficient permissions to copy, move and rename files in the ‘By
Choice Activities’ folder. If you do not have such permission the 
computer will tell you when you try to do this.

Go to the Edit menu and then Set student work. The following 
dialog box will appear:

This displays the complete range of activities in the list box on the
left. These can be expanded to see the contents by clicking on the
small + sign next to each folder. Follow the order of steps indicated
on the dialog box.

1. Type in the name of the student to whom you want to allocate 
work. It is also quite likely that this is not simply a student, but a 
group – e.g. green group. 

2. If you want the folder to display an image relating to the student 
or group then click on the Browse button. Find the picture you 
want. This will be copied into the student folder. It will not be 
moved from its original place. 

3. Click on Create/Open folder when you are happy with steps1 and 2.
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Your dialog box will now look similar to the one shown below. 

Now allocate the sequence of activities. If you get the order wrong it
does not matter as it can be changed later. 

Use the left list box, click on the + sign on the folder with the activity
you want to use. Highlight the activity name by clicking on it. You
will see the thumbnail of the activity in the lower right box. If this is
the activity you want then click Add->. Continue to add files from this
or other folders until you have selected all those that you need. The
dialog box will now look something like this:

If you make a mistake and transfer a file you do not want, then click
on the file in the right hand list box and then click on the Delete
button.
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Editing a 
student file

Deleting a 
student file

If you want to re-order the activities you can select an activity in the
right hand list box and use the To top, Up, To bottom and Down
buttons to move them in the list. 

When you have finished select Done.

Go to the Edit menu and then Set student work. In the dialog box
type the name of the student and select the Create/Open folder
button. You will see the student’s picture appear and their folder of
work. You can then change any of the activities or the student’s 
picture. 

When you have finished select Done.

Go to the Edit menu and then Set student work. Select Delete 
student folder. From the dialog box that appears select the student
folder and the Delete button. Note that this operation is irreversible.
You can select more than one student at a time by holding down Ctrl
while you select the students. Select Finished when you have deleted
the student folders. Then select Done from the main dialog box.
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